Ultimate Web Site Drop Down Menu Forum

Ultimate Web Site Drop Down Menu Forum (http://www.udm4.com/forum/index.php)
-   Troubleshooting (http://www.udm4.com/forum/forumdisplay.php?f=12)
-   -   Menu always opened, mouseover not working, no error message (http://www.udm4.com/forum/showthread.php?t=1413)

rbachl 06-02-2008 10:47 PM

Menu always opened, mouseover not working, no error message
 
I cannot get the udm4 menus working and would need some help.
The menu is permanently displayed, mouseover is not working, but there is no error message.
When looking at the source code generated by the web server, everything seems to be ok. In particular, the following lines are included:

(----snippet 1-----)
<link rel="stylesheet" type="text/css" media="screen,projection" href="udm/udm-style.php" />

(----snippet 2-----)
<ul id="udm" class="udm" ><li><a href="./index.php?ee_lang=eng&amp;u=">Browse&nbsp;Gallerie s&nbsp;</a><ul><li><a href="list.php?exhibition=1&amp;u=&amp;ee_lang=eng " title="1 photo">First exhibition</a></li><li><a href="./" title="--------------------------------">--------------------------------</a></li><li><a href="./guestbook.php?u=&amp;ee_lang=eng" title="Guestbook">Guestbook</a></li><li><a href="./news.php?u=&amp;ee_lang=eng" title="News">News</a></li><li><a href="./list.php?exhibition=all&amp;select_output=ratings& amp;u=&amp;ee_lang=eng" title="Browse Ratings">Browse Ratings</a></li><li><a href="./sitemap.php?u=&amp;ee_lang=eng" title="Gallery Map">Gallery Map</a></li><li><a href="./gear.php?u=&amp;ee_lang=eng" title="Gear List">Gear List</a></li><li><a href="./comments.php?u=&amp;ee_lang=eng" title="Photo Comment Browser">Photo Comment Browser</a></li></ul></li></ul>

(----snippet 3-----)
<script type="text/javascript" src="udm/udm-dom.php"></script>

udm-dom.php, udm-style.php and udm-custom.ini are all readable in subdirectory udm. The paths to udm-custom.ini are set correctly in the files udm-dom.php and udm-styles.php.

The php and apache versions are a bit dated, but I have not encountered any other problems with this before. I was following the description for integrating udm in Exhibit Engine as described in http://photography-on-the.net/forum/...d.php?t=223312
which includes all other details of the menu configuration.

Do you have any suggestion what I could modify or check? Thank you.

vinyl-junkie 06-03-2008 02:19 PM

It might be helpful if you posted a link to your site. Perhaps we might see something that needs to be fixed. Also, you might also want to temporarily remove any non-UDM javascripts from your page to see if that fixes anything for you. It's possible that other javascripts are conflicting with UDM.

06-04-2008 03:08 AM

Can you post a link to the site? I did a quick check by replacing your <ul> / <li> list with a default configuration and everything worked fine.

rbachl 06-07-2008 12:09 PM

Sample page
 
Thank you for the replies, and sorry for keeping you waiting with the access to the website. I was only able to reconfigure the webserver at the weekend, I hope that public access is working now:

http://wanderlust.webhop.org/EE2

You will find the menu in the upper left corner.

I have no Java scripts installed. Everything works with PHP.

vinyl-junkie 06-07-2008 03:09 PM

In your file udm-style.php, the very first statement sets the value of $config. What does that statement look like? I believe that may be the problem.

rbachl 06-07-2008 04:03 PM

I have read that somebody had problems with statements of the form:

$config = $_SERVER['DOCUMENT_ROOT'] . '/path_from_doc_root_to_udm_custom_ini/udm-custom.ini';

Therefore I am using the absolute path as follows:

$config = '/absolute_path_to_udm-custom_ini/udm-custom.ini';

I was also trying the relative path as suggested by the
"Exhibition Engine" gallery forum, cf.
http://photography-on-the.net/forum/...d.php?t=223312

$config = 'udm-custom.ini';


None of the above settings seem to work. I am a bit lost here.

vinyl-junkie 06-07-2008 07:36 PM

Try this:
Code:

$config = 'EE2/udm/udm-custom.ini';
What you have may already be the equivalent of this, but I'm still convinced this is where the problem lies. When a problem like yours has come up before in the forums, this is usually what needs to change to fix it.

rbachl 06-08-2008 12:52 AM

Thank you for the reply. I did not try this particular path setting before, but unfortunately it does not work either. In the meantime, I have tried the following 5 options in udm-dom.php and udm-style.php:

// Option 1: suggested by udm
//$config = $_SERVER['DOCUMENT_ROOT'] . '/EE2/udm/udm-custom.ini';
// Option 2: absolute path
//$config = '/share/MD0_DATA/Qweb/EE2/udm/udm-custom.ini';
// Option 3: relative path suggested by EE2
//$config = 'udm-custom.ini';
// Option 4: relative to document root suggested in forum
//$config = 'EE2/udm/udm-custom.ini';
// Option 5: relative to EE2
$config = 'udm/udm-custom.ini';

With every test, I have made sure that the browser cache was cleared, but I could not get the udm menu working so far.

vinyl-junkie 06-08-2008 03:18 AM

Move the following bit of code to where it is just underneath the <body> tag:

Code:

<!-- PHP generated menu script [any modules or extensions must come AFTER this] -->
<script type="text/javascript" src="udm/udm-dom.php"></script>

Also, you need these three scripts inside the <head> section of your page:

Code:

<!-- ULTIMATE DROP DOWN MENU Version 4.5 by Brothercake -->
<!-- http://www.udm4.com/ -->
<script type="text/javascript"
        src="udm/udm-custom.js"></script>
<script type="text/javascript"
        src="udm/udm-control.js"></script>
<script type="text/javascript"
        src="udm/udm-style.js"></script>

Make sure those files are on the server as well.

Let us know if this solves your problem.

rbachl 06-08-2008 05:02 PM

Sorry for being a bit ignorant, but I thought that the PHP configuration of udm does not requires the js files? The js files are not mentioned in the PHP configuration http://www.udm4.com/manual/setup/scriptsphp/
and they are not mentioned in the forum describing integration of udm in the Exhibition Engine.

The web pages are dynamically generated by Exhibition Engine. For making the changes you are suggesting, I would need to learn and modify the Exhibition Engine code, which is something I did not plan to do...

If the flaw is with my PHP version not supporting some of the statements in the udm files, maybe I can first provide the PHP configuration (phpinfo) for some crosscheck. If this does not yield a hint about the problem, I could include statements for debugging in the udm code? What do you think?

Unfortunately, I cannot just update or recompile php since this is on a ARM based system where I do not have a toolchain for.
Java is also missing on the webserver.


All times are GMT. The time now is 08:23 AM.

Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.