Ultimate Web Site Drop Down Menu Forum

Ultimate Web Site Drop Down Menu Forum (http://www.udm4.com/forum/index.php)
-   Troubleshooting (http://www.udm4.com/forum/forumdisplay.php?f=12)
-   -   Firefox 2.0.0.11 not working while IE7 just fine (http://www.udm4.com/forum/showthread.php?t=758)

ddc312 12-05-2007 09:59 PM

Firefox 2.0.0.11 not working while IE7 just fine
 
Hello,

I've installed UDM in a very basic way with a little bit of custom style.
http://www.hivcenternyc.org/test1.htm

It works great in IE7 but not at all in Firefox. I've tried the following:

1) Tidied elements with a validator
2) Removed the custom style and replaced with original

Neither has helped. I do notice that one difference stands out, the lack of images in the Firefox rendered version.

Can anyone help?
Darren Carter, MD

vinyl-junkie 12-06-2007 02:21 AM

When I ran your page through the W3C validator, I got 26 errors. You might want to try fixing those and see if that cures your menu problems. After that, if you still have problems, let us know. We'll be glad to help if we can.

bcarl314 12-06-2007 06:23 AM

Looks like your ul / li code is not valid. You have:

Code:

<ul id="udm" class="udm">
        <li><a class="nohref">About the Center</a></li>
                <ul>
                        <li><a href="/index.htm">Home</a>
                        </li>

                        <li><a href="/whoweare/">Who We Are</a>
                        </li>
                        <li><a href="/contact/">Contact</a>
                        </li>
                        <li><a href="/whoweare/faqs.html">FAQs</a></li>
                        <li><a href="/newsletter/archives.html">Newsletters</a></li>
                </ul>

        <li><a class="nohref">Research Portfolio</a></li>
                <ul>
                        <li><a href="/people/">Researchers and Staff</a></li>
                        <li><a href="/whoweare/organization.html">Cores</a></li>
                        <li><a href="/research/">Projects</a></li>
                        <li><a href="/international/">International Research</a></li>

                </ul>
        <li><a class="nohref">Activities</a></li>
                <ul>
                        <li><a href="/lectures/">Grand Rounds</a></li>
                        <li><a href="/publications/">Publications</a></li>
                        <li><a href="/training/">Training</a></li>
                        <li><a href="/videos/">Videos</a></li>

                </ul>
</ul>

try this instead:

Code:

<ul id="udm" class="udm">
        <li><a class="nohref">About the Center</a>
                <ul>
                        <li><a href="/index.htm">Home</a>
                        </li>

                        <li><a href="/whoweare/">Who We Are</a>
                        </li>
                        <li><a href="/contact/">Contact</a>
                        </li>
                        <li><a href="/whoweare/faqs.html">FAQs</a></li>
                        <li><a href="/newsletter/archives.html">Newsletters</a></li>
                </ul>
        </li>
        <li><a class="nohref">Research Portfolio</a>
                <ul>
                        <li><a href="/people/">Researchers and Staff</a></li>
                        <li><a href="/whoweare/organization.html">Cores</a></li>
                        <li><a href="/research/">Projects</a></li>
                        <li><a href="/international/">International Research</a></li>

                </ul>
        </li>
        <li><a class="nohref">Activities</a>
                <ul>
                        <li><a href="/lectures/">Grand Rounds</a></li>
                        <li><a href="/publications/">Publications</a></li>
                        <li><a href="/training/">Training</a></li>
                        <li><a href="/videos/">Videos</a></li>

                </ul>
        </li>
</ul>


ddc312 12-06-2007 10:25 PM

Much obliged!
 
The problem with the nested <li> was it. Thanks for seeing that. Much easier than fixing 26 validator problems first.

DC

vinyl-junkie 12-07-2007 03:50 AM

You should still fix those other validation problems, if not for the purpose of getting UDM to work, at least for possible page rendering problems in different browsers.


All times are GMT. The time now is 02:05 AM.

Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.