Ultimate Web Site Drop Down Menu Forum

Ultimate Web Site Drop Down Menu Forum (http://www.udm4.com/forum/index.php)
-   Troubleshooting (http://www.udm4.com/forum/forumdisplay.php?f=12)
-   -   Unable to see the menu indicator character/image (http://www.udm4.com/forum/showthread.php?t=6329)

p9142 01-28-2009 09:33 PM

Unable to see the menu indicator character/image
 
Can someone please explain to me why I can see the menu indicator image for this page: http://www.wiu.edu/users/ppc102/menu1/ but not for this page http://www.wiu.edu/users/ppc102/menu1/baseball/

My un.items portion of udm-custom.js script looks like this:

Code:

        "right-green.gif",// menu indicator character/image ["text"|"image.gif"|"none"]
        "right-red.gif",// menu indicator rollover character/image ["text"|"image.gif"|"none"] (must be same type)
        "7",                // clipping width of indicator image ["n" pixels] (only when using image arrows)
        "..",                // alt text of indicator image ["text"] (only when using image arrows)
        ];

The first page has this code to reference the menus:
Code:

<!-- http://www.udm4.com/ -->
<script type="text/javascript"
        src="udm-resources/udm-custom.js"></script>
<script type="text/javascript"
        src="udm-resources/udm-control.js"></script>
<script type="text/javascript"
        src="udm-resources/udm-style.js"></script>
</head>

while the second page has this:
Code:

<!-- http://www.udm4.com/ -->
<script type="text/javascript"
        src="../udm-resources/udm-custom.js"></script>
<script type="text/javascript"
        src="../udm-resources/udm-control.js"></script>
<script type="text/javascript"
        src="../udm-resources/udm-style.js"></script>
</head>

Why would the ../ make the images go away while the script keeps working?

p9142 01-29-2009 10:15 PM

I'm sure that someone has run into this problem in the past. Isn't there a way to have your udm-resources folder be in a different folder than the html code? I can only get the images to show up when I have them in the same folder:

Code:

<script type="text/javascript"
        src="/udm-resources/udm-custom.js"></script>


when I place my html file on level deeper in the site folder structure, my menus still work when I use this code, but the images disappear:

Code:

<script type="text/javascript"
        src="../udm-resources/udm-custom.js"></script>


01-30-2009 01:14 AM

In your udm-custom.js file change this

Code:

//path to images folder
um.baseSRC = "udm-resources/";

to this...

Code:

//path to images folder
um.baseSRC = "/menu1/udm-resources/";

The problem is a pathing issue. Using an absolute path (as opposed to a relative one) should solve the problem.

p9142 02-06-2009 06:08 PM

That did it. Thank you so much for your help.


All times are GMT. The time now is 07:06 AM.

Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.