Unread 01-13-2008, 11:17 PM
bramms62 bramms62 is offline
Junior Member
Join Date: Jan 2008
Posts: 2
  #1  
Default IE6 & IE7 Issue?

I have a single horizontal menu bar on my web page. The menu works great in other browsers. However, when viewing page in IE6 and IE7, the menu displays, but will not allow any clicks to open the submenus. It appears to hang. I see a 'javascript:void(0)' message displayed in the lower left corner of the bottom status bar.
I have experimented with the 'defer' option and the 'trigger' variable, but nothing appears to make a difference. I have also, checked to see if I have a css conflict, but can't seem to find one.
When I run site in FF and watch the error console, I don't get any javascript errors.
Any ideas on what is wrong or missing?
Reply With Quote
Unread 01-14-2008, 03:40 PM
bramms62 bramms62 is offline
Junior Member
Join Date: Jan 2008
Posts: 2
  #2  
Default Oops, I got it.

Basically, it was a malformed list which was causing the problem.
I have a program which builds the list dynamically, which is quite lengthy, I was missing a close ul tag deep in a couple of the submenus. Apparently, IE can't handle this problem while the other browsers could.
Reply With Quote
Unread 01-14-2008, 04:01 PM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #3  
Default

Glad to know that you got your problem solved.

Lesson learned: Always validate your page first, before considering other problems with your code.
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 01:23 AM.


Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.