Unread 07-03-2008, 10:35 PM
kokimo1 kokimo1 is offline
Junior Member
Join Date: Jul 2008
Posts: 3
  #1  
Default Not working in IE7 with CSS disabled

Hello,

With CSS disabled, UDM doesn't show up in IE7 (using the Paciello Group web accessibility toolbar). Does anyone have any idea why? I can't seem to figure it out.

Also, the arrows don't show up on pages that aren't in root. I checked the path in udm-custom.js and it looks right (I searched the forums before posting).
Code:
//path to images folder
um.baseSRC = "udm-resources/";
It should work, but it doesn't. Any ideas?

my test site is here.

Any help would be greatly appreciated.
Reply With Quote
Unread 07-04-2008, 03:36 AM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #2  
Default

I'm not sure I follow you. I don't have a tool to disable CSS in IE but I have one in FF. When I disable CSS in FF, your menu appears as an unordered list, which is what UDM4 should do. Are you saying that your menu doesn't show up at all or that it appears as an unordered list?
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Unread 07-09-2008, 04:01 PM
kokimo1 kokimo1 is offline
Junior Member
Join Date: Jul 2008
Posts: 3
  #3  
Default

When I disable CSS in Firefox (Mozilla Accessibility Extension v1.01 toolbar), it looks like this. As you can see, the menu is still there but the styling for the rest of the page is removed.





With CSS disabled in IE (Paciello Group WAT v2.0 toolbar), it looks like this. The UDM menu is replaced with an unordered list, but the second layer links are nowhere to be found.





Is this menu supposed to work with CSS disabled? It seems to work in Firefox without CSS (I'm guessing the firefox toolbar we use overlooks the CSS in the javascript). The department I'm designing this site for seems to think it's supposed to work with CSS disabled (they use the same Firefox toolbar)......should it work or should it not? If so, what am I doing wrong?

Also, why don't the second layer links show up in IE (with CSS disabled)?

Last edited by kokimo1 : 07-09-2008 at 04:25 PM.
Reply With Quote
Unread 07-10-2008, 05:14 AM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #4  
Default

My guess is that you have two stylesheets on your page -- one that UDM4 uses and the other being for the rest of your site. This is what I have with my own site.

I don't know about that particular add-on that you have with Firefox, but I have a similar add-on called Web Developer. If I disable the UDM4 stylesheet, I get an unordered list on the page. If I disable my main stylesheet, I lose all the styles for the rest of the page. Both of these behaviors are as expected.

I'm not familiar with the toolbar you say you're using with Internet Explorer, but I suspect it is disabling both your main stylesheet and your UDM4 stylesheet. Again, when the stylesheet(s) is disabled, the behavior is the same as I described above, and is expected.

The UDM4 stylesheet is what is used to give the particular appearance to the menu. Without it, the menu simply appears as an unordered list. Your menu links will still work, regardless of the menu's appearance.

Hope this helps.
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Unread 07-10-2008, 04:03 PM
kokimo1 kokimo1 is offline
Junior Member
Join Date: Jul 2008
Posts: 3
  #5  
Default

I only have one stylesheet, which handles styling for everything but UDM, so it can't be that. I think the toolbar is disabling the stylesheet but not the styling in the javascript (in udm-custom.js). The toolbar was coded by an accessibility expert at U of I - I'll be sure to pass this information along to him.

This still doesn't solve the problem with IE, though. Yes, the menu does appear as an unordered list, but only the top level links are shown. The same thing seems to be happening with the Cambridge Blue demo page (http://www.udm4.com/demos/style-blue.php), so it can't be my code, right?

So....is only the top level of the unordered list supposed to be shown when CSS is disabled?

Thanks for all your help, vinyl-junkie.
Reply With Quote
Unread 07-11-2008, 03:12 AM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #6  
Default

The entire Cambridge Blue menu shows up as an unordered list for me in Internet Explorer when I have CSS disabled. Does that not happen for you?

I notice in taking a closer look at your web page, when I disable CSS in IE, it's doing the same thing for me -- only showing the top level menu links. I'm not sure what is causing that. However, I would like for you to try a couple of things to try and narrow it down.

Change this statement on your page:

Code:
<body class="thrColHybHdr" onload="changedrcimage();initCITA()" >
to this:

Code:
<body>
Does that make any difference in the problem?

Also, try commenting out all your javascripts except the ones needed for UDM. Does that make any difference?
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 12:30 AM.


Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.