Go Back   Ultimate Web Site Drop Down Menu Forum > UDM4 > Troubleshooting
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
Thread Tools Display Modes
Unread 10-06-2007, 06:05 PM
jetwbt jetwbt is offline
Junior Member
Join Date: Oct 2007
Posts: 2
  #1  
Question Expanding menus width appears not to change with settings

Hi,

I am trying to use the expanding menus. They expand perfectly. The only problem seems to be that the styles to apply to each menu item ($um['menus']) width is consistently being ignored. I must be missing something as it seems to revert to the same value of about 120px. I have tried setting it to 200px, to 240 px, to 16em, even down to 50px, but none changed it from its current width. I'd like it to be at 240px, so the menus won't scroll down beyond the page break. The page I'm playing with is at:
http://www.taism.com/new_web/index6.php
Is there any other setting besides the width of each menu item I need to change?

Any help would be most appreciated.

Many thanks,

Brian
Reply With Quote
Unread 10-07-2007, 04:09 PM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #2  
Default

Without being able to see your menu code, it's a little hard to advise you on what you might be missing or doing incorrectly. You might want to post the code for udm-style.php, if you'd like for us to take a look at your code. In the meantime, you might want to make sure that you've followed all the directions in the Creating An Expanding Menu tutorial.
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Unread 10-07-2007, 04:19 PM
jetwbt jetwbt is offline
Junior Member
Join Date: Oct 2007
Posts: 2
  #3  
Smile Figured it out

It was the adding additional styles to the style page that was the problem.

.library { font-family: Verdana, Arial, Helvetica, sans-serif; font-size: medium; color: #000099; } /* expanding menu styling */#udm ul { margin-left:0 !important; margin-top:1px !important; width:250px !important; w\idth:240px !important; }#udm ul ul { width:240px !important; w\idth:230px !important; border-style:dashed; background-color:#ffe; }#udm ul ul ul { width:230px !important; w\idth:220px !important; border-style:dotted; background-color:#ffd; }/* give all anchors a hand cursor */#udm a { cursorointer !important; cursor:hand !important; }

Thanks,

Brian
Reply With Quote
Unread 10-07-2007, 04:31 PM
vinyl-junkie vinyl-junkie is offline
Moderator
Join Date: Aug 2007
Posts: 114
  #4  
Default

The easiest way to solve this would be to remove those additional styles one at a time to see which one of them contains the offending code. If a particular style appears not to cause problems, put it back in the code, then remove the next one. Repeat this process until you've isolated the problem.

Hope this helps.
__________________
Music Around The World - Collecting tips, trade
and want lists, album reviews, & more
SNAP to it!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:42 PM.


Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.